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PCB EDA Tutorial
Laboratory 2 Addendum 1
Working With Allegro Footprints
CMPE174, Intro to EDA Tools
S.C. Petersen

1. INTRODUCTION AND OBJECTIVES
This section continues the earlier discussion begun in Lab-1, section 5, where Allegro’s Package editor was used to
manage existing footprints and for mapping specific footprints back into Capture for later use in Allegro.
Unfortunately, actually creating or modifying footprints required a deeper understanding than one possessed at that
time, even though the logical point in the design flow for doing this is usually during the schematic capture phase
when symbols are being tied to their PCB footprints. Thus, having completed at least one board, it should now be
possible to grasp the fundamentals of making footprints. We will create two, one with vias and one without.
Creating footprints is essentially an exercise in properly translating dimensioned mechanical drawings. Knowing
how to read mechanical drawings (aka “prints”), whether 3-view, isometric or orthographic, makes translating such
drawings into a well-designed footprint relative easy. Such necessary drawings are usually found at the end of a
component’s datasheet, where several different ways of dimensioning parts can be encountered. It is worthwhile to
be familiar with these standards before beginning.
DECIMAL INCH STANDARD – Many domestic manufacturers use this standard, where an inch is divided into 0.001
inch increments (also known as a “mil” or thousandth of an inch), so there are 1000 mils per inch. This is a very easy
and sane way to guage sizes, since the “decimal” part is easily read from a mechnical scale or micrometer.
METRIC STANDARD – By contrast, most foreign manufacturers use this standard, where SI units are used and
generally expressed in millimeters. Parts dimensioned in mm usually require some numeric conversion to decimal
inches. A few conversions, accurate to 3 significant figures, that you should memorize are:




25.4 mm  1.00 inch or 1000 mils , hence it follows by inspection that:
2.54 mm = 0.100 inch or 100 mils
(2.54mm 2)  1.27 mm  50 mils

Many components are created with 50 or 100 mil pin or wire spacings, so a quick look at a set of metric dimensions
will instantly reveal this. Parts with true millimeter dimensions, like 2.00 mm must be converted to decimal inches
with a calculator.
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2. CREATING A THROUGH-HOLE FOOTPRINT – In this example, we will create a new footprint for a 1uF/
50V aluminum electrolytic radial-leaded capacitor. Actually, a suitable footprint can be found in the pcb_lib_Orcad
TM_CYCLND library, needing at most a change in drill size. But we will create it from scratch to show how things
work. This capacitor requires two plated through-hole padstacks for physically mounting and electrically connecting
to it.
The first step is to have or make a mechanical drawing for the part. Yes, believe it or not, we sometimes must resort
to measuring a specimen. This is not as accurate as a real drawing provided by a manufacturer, but often works just
as well. Having a linear dial micrometer accurate to 0.001 inch is quite useful for this, especially for determining
appropriate drill sizes from measured wire diameters.
An excerpt from the datasheet for the capacitor is shown below. The component datasheet was downloaded from
Digikey while I was finding and ordering this part related to one of the final projects. It can be found in
…lab4_projects\audioamplifier\datasheets\ElectrolyticCap.pdf, since it’s used particularly in the audio amp
project (other projects too), where it’s cited with different values (and different possible sizes, each requiring their
own footprint).
The screen shot
following is a twodimensional (2-D)
view, i.e. two views
of the usual three
possible: a left-side
view (on the left) and bottom view (on the right). Classic 2-D views are left, right and top or bottom views. Be
careful to distinguish between top and bottom views; here it doesn’t matter since the capacitor’s radial-leaded wires
are symmetrical about the axis of revolution. Note the shorter lead is negative however.

Towards the end of the datasheet we find the wanted
1uF/50V dimensions; an excerpt is shown. We note
the case size,  DXL = 5 X 11 [mm]. Hence our
dimensions are:
Width,  D  5 mm  196.85 inch  200 mils
Lead Spacing, F   d mm  2.0  0.5  100 mils .
Height,
11.5 mm
L  1.5max  11.5 
 453 mils  0.5 inch
mm
25.4
inch
Wire diameter =
0.5 mm
D 
 19.685 mils  20 mils
mm
25.4
inch
Adding 3 mils for plating allowance gives us 23 mils
minimum; the neareast APC drill size above this is 28
mils, so we will use a 28 mil drill.
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Launch Allegro PCB Design XL and start the new footprint by choosing File → New (or use the icon).
Specify Package Symbol in the Drawing Type list. This changes Allegro to “Symbol mode”, rather than
“Board mode” you used in the previous lab. Anytime we create a new symbol, as we are here, or otherwise
open any symbol drawing file (having extension *.dra), Allegro changes to symbol mode. Remember, this mode is
tailored for use with footprints (Cadence calls them “packages”) so it necessarily lacks some of the features usually
available when working with boards. Since you should already be familiar with Allegro in Board mode, these will
obvious by their absence. Especially note that symbol mode works with only a subset of the classes, namely, those
most directly applicable to individual footprint symbols.
We must also specify a name for our new footprint.
Naming footprints is really something of an art. Perusing
Allegro’s and the older imported Oracd libraries reveals
that most are generic; i.e., they apply to a large class of
components having the same physical footprint. We will
follow that approach here and avoid naming it too
specifically, like “1uF_50V_Cap”. The name should,
however, fully encapsulate the various mechanical
parameters noted above. Hence, it needs to refer to a
capacitor with a diameter of 200 mils, lead spacing of
100 mils and 28 mil drills; so we’ll enter “C_200D_100LS_28D” for the name. Later, when you’re looking for a
suitable footprint, the name will go a long way to defining what the package symbol applies to. After pressing OK,
Allegro will enter symbol mode. Also, be sure the Project Directory is your working symbols folder (browse to it if
necessary) and check Change Directory. Import parameter file “symbol_mode.prm” to set Allegro’s default colors
and text sizes when working in this mode. These parameters will be saved with the new part. You can change them
later if you like. Be sure to set the Extents in the Design Parameter Editor to something small, like 2000 by 2000
mils; you should also be working in mils with 1 decimal place accuracy, and make the non-etch grid 50 mils.
Making Padstacks – The first step is to select or create the necessary padstacks. Since this is a polarized capacitor
having two mounting wires, it obviously needs two 28 mil padstacks, but one will be square, the other round to
distinguish plus and minus. Create both padstacks now, saving them in your …Handset\lib\padstacks folder. Doing
this requires that we open the Padstack Designer briefly discussed in the last lab. The best way to proceed is to
choose a padstack that’s close to what is wanted, place it on the new footprint, and then modify it. Before doing that,
study the simple 2-view orthogonal drawing showing most of the basic padstack dimensional variables. Briefly, these
are defined as follows:
 Ds = Drilled hole size, 28 mils in our case.
 Pa = Plating allowance diameter. Amount of
additional copper plated inside the raw drilled
hole; typically this is taken to be 3 mils. Since
this is a diameter, the thickness is 1.5 mils or
Pa / 2 as shown.
 Pt = the original board plating thickness before
drilling. This can be calculated from the board’s
area plating density, typically given as 2 or 3 oz.
copper per square inch.
 Ar = Top or bottom-side annular ring width,

Ar 




R p  Ds  Pa
2

, typically 10 mils or

more.
Rp = Regular pad diameter (top and bottom).
This dimension can apply to inner etch layers
(not shown) as well. This can be other shapes
besides round (square, oblong etc.).
Sm = Soldermask antipad diameter. Typically at
least 5 mils larger than the regular pad diameter
it surrounds.
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Tb = Unplated raw PCB base material, typically 60 mils for FR4.

Padstacks are automatically classified by Allegro depending on what layers they may potentially connect:
The figure shown1 summarizes the first three of the four classic padstack
types:
1.

Blind vias are only partially drilled, but start on the top or
bottom-sides (hence “blind” on one side).

2.

Buried vias connect only inner layers and are “blind” to from
both sides.

3.

Through-hole padstacks are drilled through the entire stackup.

4. Single padstacks have one pad (may be any shape) with no
drilled hole. This is for surface-mount (SM) footprints.
Allegro also allows B/B (“blind and buried) vias to be specified as Microvias. These are holes, typically under 6 mils
created with lasers for specific purposes, like fanning out high-density ball grid arrays. Moreover, up to 16 etch
layers can be defined in a library padstack.
The library padstack we want to create now for this generic capacitor part is clearly a simple 2-layer through-hole
type having equivalent regular pads and solder-mask diameters on both sides. Beginning with the drill size of 28
mils, the annular ring should be at least 10 mils. Therefore, sizing making the regular pads on each side 50 mils,
results in Ar  12.5 mils after plating or 11 before plating. The soldermask antipads (voided areas of enamel) should
have 5 mil annular rings around the regular pads, making S m  60 mils by inpection. Choose menu sequence Tools

→ Padstack → Modify Library Padstack and choose any suitable padstack from Allegro’s library. If you want to
start with one of your own, then select Modify Design Padstack (if available). This gets you into the Padstack
Designer. Necessary entries to define a new round padstack using positive artwork is summarized below. Note that
we’re not specifiying any particular figure or character, since this would normally be defined locally after the
padstack has been used in a particular design; you did this in the last lab.

Edit each layer by first selecting it with the mouse in the Layer column; this will populate the three columns with that
layer’s current settings. Note the film-mask layers are not shown but they should be the same as those for the
1

Copied from Allegro PCB Editor User Guide: Defining and Developing Libraries, Ch-2, Library Padstacks.
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pastmask layers. The two columns: Thermal Relief and Anti Pad are only useful with negative artwork layers. An indepth discussion of negative artwork is beyond the scope of these labs. Suffice to say that for positive artwork,
Allegro uses autovoiding with dynamic shapes to create thermal reliefs for you. When negative layers are defined,
copper pours are assumed to already exist and necessary thermal reliefs and voids are not automatically created for
you; rather, they are defined by entries from these two latter columns. Since our stackup only specifies positive
artwork layers only we won’t pursue this topic furher. When you’re finished, choose the Designer’s menu sequence
File→Save As… and save it as “P50R28.pad” in your padstacks’ folder. This padstack will now show up in the
library list of those available along with Allegro’s and any padstacks that happen to present in your working
directory (this should be your symbols’ folder). Later, after the padstack has been placed (instanced), it will then
appear as a design padstack, i.e. one that is part of your current design work.
Go ahead now and instance or place this first padstack as pin-2 in the new footprint (the convention is square
pins are always pin-1; we’ll create and place that next). Set the non-etch grid to 50 mils and choose Layout
→ Pins (or use the icon) to change the context. Then use the Options’ panel to
select the new padstack and place it anywhere you like. Note the fields in this
context are very powerful. Array’s of pins can quickly be created with specific
geometries. If you were creating a part that had multiple pins, you could also
place them manually one-by-one and have the pin numbers imcrement
automatically. It’s worth the time to experiment with these settings to get familiar
with what the fields do and perceive how they can best be used. One critical point
that needs to be here is the distinction between Connect padstacks and
Mechanical padstacks. The former are treated as electrical objects having pin
numbers associated with nets, while the latter are not. The 125 mil mounting
holes you placed at the beginning of the last lab are an example. It is possible to
change pin types after a padstack appears in a design.
Now create another padstack having the same drill except make it square instead
of round. The easiest way is to modify the one you just made, and save it as
“P50S28.pad”, only Regular Pads need to to be changed. The relevant screen shot is shown below. Note that since
the new padstack is now part of the footprint, you can choose Tools → Padstack → Modify Design Padstack
rather than the library; this will shorten the selection list considerably.
After saving the new square padstack, place it as pin-1
100 mils from the round pin (take advantage of Relative
XY mode to measure out the 100 mils for the next pin
placement). Your two new padstacks should look
similar to that shown (I moved the text around a little
after placement).
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We now need to make two line drawings as follows. You should already know how these are used from the last lab:


Silk-screen drawing of that will appear on the finished PCB, and placed on the Package Geometry / SST
layer. This will be a 200 mil diameter line drawing with 8 mil line width.



Assembly top drawing of the component’s outline on the Package Geometry / AST layer.
For this part, we’ll make the AST drawing the same as the SST. Generally, it doesn’t have to, since it never
actually appears on the physical PCB.
Draw both of these using the Circle tool: follow Add →
Circle. Set the Line width to 8 and the Line font to Solid in the
Options’ panel. Copy the circle from between layers or draw it
again.. Note that Allegro’s footprint’s are 0 mil lines, but this
just means we have to manually change them after placing
them, so it’s better to define them the way we want now.
Generally, SST draws should be greater than 5 mils or the ink
won’t show properly; 8 mils is a good nominal size to use, but
the AST thickness is up to you.
The result is shown to the left.

Adding the Placement Outline – Every part must have a filled shape representing the part’s physical placement
boundary placement boundary. This provides the DRC and potential autorouter a means to identify what board area
is occupied by the component. These boundaries can be defined for either the top or bottom or both, depending on
physical characteristics of the component to prevent overlap of adjacent components (which will also have their own
place outlines). We’ll place only a single shape on the Package Geometry / Place_Bound_Top layer. Since the part’s
diameter is 200 mils, a 220 mil diameter round boundry about footprint should be sufficient. Do this using a filled
round shape. If you’re still not sure how to do this, first set the class / sub-class and then choose Shape → Circular
(or use the icon); set the Shape Grid in the Options’ panel for 10 mils and start at the very center of the part moving
the mouse out 110 mils. Be sure to use Relative XY mode! It should like the graphic shot below.
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The last step is to add mandatory and any optional text.2 The graphic below nicely summarizes the usual text that
normally appears in most of Allegro library symbol parts (ref.: dip8_3.dra). Study this carefully and be sure you
really understand it.

Allegro requires there be at least one instance of text in the REFDES class; the others are optional. And it doesn’t
really matter what is actually entered, since it serves merely as a place holder indicating a field; the string
substitution is based only on the class. Thus, we will enter strings having more meaning than just asterisks. Before
proceeding, note the assembly-top fields are inside the part outline, while the silk-screen fields are outside. This
makes sense, since the SST is mean to actually appear on a PCB, while the AST isn’t. Enter text fields now,
arranging them about the part, based on the class / sub-classes noted above and text strings indicated as follows:






Refdes
Device Type
Component Value
Tolerance
User Part Number

C*
DEV
VAL
TOL
UPN

Make the reference designators text size 3 and all
the rest 2. Your text should look something like that
shown. The rightmost column is all the silk-screen
fields; those on the left are assembly-top.

As a final touch, identify the the positive pin by placing “+” signs near pin-1 on
both the Package Geometry SST and AST layers. Create these as two
orthogonal line segments 30 mils long having 6 mil widths. Choose Add →
Line (or use the icon shown). Since lines follow the non-etch grid setting,
change it to 5 mils for this operation so you can draw a nice looking “+” sign.ith
the non-etch grid still to 5 mils, re-position the segments the way you would like
it to appear when Allegro loads the footprint. When finished, save the new
footprint.

2

For a general discussion, refer to Allegro PCB Editor User Guide: Defining and Developing Libraries, Working with Symbols,
pgs. 29-31.
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Defining the Drawing Origin – Every footprint must have a reference point to be used whenever it is selected for
placement or for moving after being placed. When creating a new part from scratch, this drawing origin is usually
nowhere near the part and must be moved to a relevant point somewhere on or nearby. Whenever a footprint is
selected for moving, Allegro will instantly relocate the part so its drawing origin is now at the mouse point’s position
when it was first selected. Thus, it behooves us to know where this point is beforehand, and so avoid the annoying
side-effect of selected parts jumping about on the screen. Generally, the center of pin-1 is most often used for this
purpose, since we also can usually quickly find this point by inspection. The drawing origin can easily be moved by
following Setup → Change Drawing Origin. Be sure the point you want coincides with the grid point used to
place pin-1 to ensure proper part alignment with the placement grid used when the part is actually placed or later
moved about.

3. CREATING A SURFACE MOUNT FOOTPRINT – For this example, we will create a new footprint for the
FM Transmitter’s 5-20 pF VCO tuning capacitor. Excerpts from the datasheet for MuRata’s TZC3 series RF

trimmer capacitors are shown below. This example also assumes you have already learned how to create a footprint
with vias in the preceding section 6.2
The datasheet was downloaded from Digikey while I was finding and ordering this part for the FM Transmitter
project. You can find it in …lab4_projects\FM Transmitter\datasheets\TZC3 Variable RF caps.pdf.

Both the Standard Type and Cross Slot Type are
shown to the left. A careful comparison of the
recommended PCB footprint found later in the
datasheet (“Land Pattern”), reveals that MuRata
recommends the same footprint for both as
shown below.

I have experience with this component and will
change the recommended SMT pad sizes
somewhat.
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Since I like to work in decimal inches, the first step is to annotate directly on the mechanical drawings what the
various toleranced dimensions are in mils. For example, the top dimension shows the pad spacing to be 5.0 mm with
a tolerance of +0, -0.5 mm; this just means it should lie between 4.5 and 5.0 mm. Converting this to mils yields
177.2 to 196.8 mils. Similarly for the 3.3 mm dimension, 3.2 to 3.4 mm translates to 126.0 to 133.8 mils. And the
width of 0.9 to 1.1 mm translates to 35.4 to 43.8 mils. The missing pad lengths have to be deduced from the other
dimensions. Hence, it will lie between 21.6 and 35.4 mils (calculation details are left to the interested student). This
technique of making dimension notes directly on the drawing and keeping them in your engineering notebook is very
useful.

We will make the pads 40 mils square and space them so their inner vertical edges are 130 mils apart.
Create a new part named “C_RF_TZC3” following following the same procedure as for the through-hole part (see
page-2). Set the non-etch grid resolution for 10 mils and, if you haven’t done so already, import parameter file
“symbol_mode.prm”.
Again, following the same general procedure as we did earlier, open and modify one of the library surface mount
padstacks. When you’re done rename it to refer to a 40 mil square SM pad, “SM40X40” and save it your padstacks
folder. Note our naming convention is based on what we did with the earlier part. Since this will be a surface mount
padstack, the only layers needing anything on them will be those related to the top layer.
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Following side-by-side screen-shots summarize how to do this using the Padstack Designer:

Note the increased decimal resolution over the earlier part, and the use of Single layer mode. After saving the part,
place the two new square SM pads so their inner edges are space by 130 mils. This raises the next question: where do
we place the second pad if we want it to be spaced 130 mils to the right? Since the pads are each 40 mils wide,
placing the second one at 170 mils will give the wanted separation. Go ahead and place both pads now.

Placement Boundary and Outline – You will find these tasks much easier if the non-etch grid is set to 5 mils. First
create the placement outline on the Package Geometry / Place_Bound_Top layer as a properly centered 130 by 220
mils (XY) filled rectangular shape. Then, using this as a guide add the part’s outline on the silk-screen and assembly
layers. Create an artistic outline on the SST and AST layers depicting the component’s outline. Typically, this need
not be very accurate, but it should at least identify the part. Shown below are the results after doing this. Don’t make
the SST linework than an 8 mil draw. The AST draw can be any size, since its presence is primarily for internal
documentation purposes. The result showing the filled boundary, SST and AST layers is shown below.
Go ahead and add the necessary text fields using the earlier discussion on page 7
as a guide. Note that since this is also a capacitor, the reference designator fields
will be the same as for the through-hole part.

The finished part should look something like that shown on the
left. Note the SST classes are along the right side, while the AST
classes begin inside the part. After finishing, save your new part.
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4. CONCLUSION
This concludes the addendum 2.1 to the second laboratory.
Oral Evaluation of your work for grading:
Your grade for this laboratory will be based on showing the instructor compentence using Allegro and understanding
things presented and discussed in the lab. Your understanding will be gauged by responses to any of the following
topics and questions.You will be asked to answer or expound on several of them.
1.
2.
3.
4.
5.
6.
7.

Explain how Allegro uses the text fields on various classes / sub-classes.
What is positive and negative artwork?
What are the four basic padstack types?
What elements are required by Allegro to be on every part symbol?
Demonstrate how to use the padstack editor.
The Placement outline. What is it and why is it necessary?
Explain why specific text fields can be anything we like.

